Реферат скачан с сайта allreferat wow ua




Скачать 331.43 Kb.
НазваниеРеферат скачан с сайта allreferat wow ua
страница2/2
Дата публикации19.04.2014
Размер331.43 Kb.
ТипРеферат
uchebilka.ru > Бухгалтерия > Реферат
1   2
([[Знач] <Парам1>[=<ДефЗнач>], ... , [Знач] <ПapaмN>[=<ДeфЗнaч>]]) [Экспорт] //Объявления локальных переменных; //Операторы; ... [Возврат;] //Операторы; ...КонецПроцедурыПараметры:|<Имя_проц> |Назначает имя процедуры. ||Знач |Необязательное ключевое слово, которое указывает на то, что || |следующий за ним параметр передается по значению, т. е. || |изменение значения формального параметра при выполнении || |процедуры никак не повлияет на фактический параметр, переданный || |при вызове процедуры. Если это ключевое слово не указано, то || |параметр процедуры передается по ссылке, то есть изменение || |внутри процедуры значения формального параметра приведет к || |изменению значения соответствующего фактического параметра. ||<Парам1>, ..., |Необязательный список формальных параметров, разделяемых ||<ПарамN> |запятыми. Значения формальных параметров должны соответствовать || |значениям передаваемых при вызове процедуры фактических || |параметров. В этом списке определяются имена каждого из || |параметров так, как они используются в тексте процедуры. Список || |формальных параметров может быть пуст. См. также: «Передача || |параметров». ||=<ДефЗнач> |Необязательная установка значения параметра по умолчанию. || |Параметры с установленными значениями по умолчанию можно || |располагать в любом месте списка формальных параметров. || |Если параметр при вызове процедуры опущен, то он принимает либо || |установленное по умолчанию значение (если оно есть) либо || |принимает «пустое» значение (значение неопределенного типа). || |Если параметру не задано значение по умолчанию, и он является || |последним в списке передаваемых параметров, то при вызове || |процедуры его нельзя опускать. || |Если параметру задано значение по умолчанию, и он является || |последним в списке, то при вызове процедуры его можно опускать в|| |списке передаваемых фактических параметров и не ставить запятую || |перед опущенным параметром. || |Если параметру не задано значения по умолчанию, то при вызове || |процедуры его можно опускать в списке передаваемых фактических || |параметров, но разделительную запятую надо ставить. ||Экспорт |Необязательное ключевое слово, которое указывает на то, что || |данная процедура является доступной из других программных || |модулей. Имеет смысл только в глобальном программном модуле. ||//Объявления |Объявляются локальные переменные, на которые можно ссылаться ||локальных |только в рамках этой процедуры (см. оператор Перем). ||переменных | ||//Операторы |Исполняемые операторы процедуры. ||Возврат |Необязательное ключевое слово, которое завершает выполнение || |процедуры и осуществляет возврат в точку программы, из которой || |было обращение к процедуре. Использование данного оператора в || |процедуре не обязательно. ||КонецПроцедуры |Обязательное ключевое слово, обозначающее конец исходного текста|| |процедуры, завершение выполнения процедуры. Возврат в точку, из || |которой было обращение к процедуре. |Описание:Ключевое слово Процедура начинает секцию исходного текста, выполнениекоторого можно инициировать из любой точки программного модуля, простоуказав Имя_процедуры со списком параметров (если параметры не передаются,то круглые скобки, тем не менее, обязательны). Если в глобальномпрограммном модуле в теле описания функции использовано ключевое словоЭкспорт, то это означает, что данная процедура является доступной из всехдругих программных модулей конфигурации. Ключевое слово Экспорт имеет смыслиспользовать только в глобальном программном модуле.ФункцияСекция описания функции.Синтаксис:Функция<Имя_функции>([[Знач]<Парам1>[=<ДефЗнач>], ... ,[Знач]<ПарамN>[=<ДефЗнач>]])[Экспорт] //Объявлениялокальных переменных; //Операторы; ... Возврат<ВозвращаемоеЗначение>; //Операторы; ...КонецФункцииПараметры:|<Имя_функции> |Назначает имя функции. ||Знач |Необязательное ключевое слово, которое указывает на то, что || |следующий за ним параметр передается по значению, т.е. || |изменение значения формального параметра при выполнении функции|| |никак не повлияет на значение фактического параметра, || |переданного при вызове функции. Если это ключевое слово не || |указано, то параметр функции передается по ссылке, то есть || |изменение внутри функции значения формального параметра || |приведет к изменению значения соответствующего фактического || |параметра. ||<Парам1>,...,<ПарамN>|Необязательный список формальных параметров, разделяемых || |запятыми. Значения формальных параметров должны соответствовать|| |значениям передаваемых при вызове функции фактических || |параметров. В этом списке определяются имена каждого из || |параметров так, как они используются в тексте функции. Список || |формальных параметров может быть пуст. ||=<ДефЗнач> |Необязательная установка значения параметра по умолчанию. || |Параметры с установленными значениями по умолчанию можно || |располагать в любом месте списка формальных параметров. || |Если параметр при вызове процедуры опущен, то он принимает либо|| |установленное по умолчанию значение (если оно есть) либо || |принимает «пустое»значение (значение неопределенного типа). || |Если параметру не задано значение по умолчанию, и он является || |последним в списке передаваемых параметров, то при вызове || |процедуры его нельзя опускать. || |Если параметру задано значение по умолчанию, и он является || |последним в списке, то при вызове процедуры его можно опускать || |в списке передаваемых фактических параметров и не ставить || |запятую перед опущенным параметром. || |Если параметру не задано значения по умолчанию, то при вызове || |процедуры его можно опускать в списке передаваемых фактических || |параметров, но разделительную запятую надо ставить. ||Экспорт |Необязательное ключевое слово, которое указывает на то, что || |данная функция является доступной из других программных || |модулей. Данное ключевое слово имеет смысл использовать только || |в глобальном программном модуле. ||//Объявлениялокальных|Объявляются локальные переменные, на которые можно ссылаться ||переменных |только в рамках этой функции. ||//Операторы |Исполняемые операторы функции. ||Возврат |Ключевое слово, которое завершает выполнение функции и || |возвращает Возвращаемое Значение в выражение, в котором || |используется функция. Использование данного ключевого слова в || |функции обязательно. ||<ВозвращаемоеЗначение|Выражение, значение которого содержит результат обращения к ||> |функции. ||КонецФункции |Обязательное ключевое слово, обозначающее конец исходного || |текста функции. |Описание:Ключевое слово Функция начинает секцию исходного текста функции, выполнениекоторой можно инициировать из любой точки программного модуля, простоуказав Имя_функции со списком параметров (если параметры не передаются, токруглые скобки, тем не менее, обязательны). Если в глобальном программноммодуле в теле описания функции использовано ключевое слово Экспорт, то этоозначает, что данная функция является доступной из всех других программныхмодулей конфигурации. Ключевое слово Экспорт имеет смысл использоватьтолько в глобальном программном модуле.Выполнение функции заканчивается обязательным оператором Возврат.Функцииотличаются от процедур только тем, что возвращают Возвращаемое Значение.Конец программной секции функции определяется по оператору КонецФункции.Вызов любой функции в тексте программного модуля можно записывать как вызовпроцедуры, т. е. в языке допускается не принимать от функции возвращаемоезначение.Переменные, объявленные в теле функции в разделеОбъявления_локальных_переменных, являются локальными переменными даннойфункции, поэтому доступны только в этой функции (за исключением случаяпередачи их как параметров при вызове других процедур, функций илиметодов).Управляющие операторыЕслиОператор условного выполнения.Синтаксис:Если <Логическое_выражение> Тогда //операторы;[ИначеЕсли <Логическое_выражение> Тогда] //операторы;[Иначе] //операторы;КонецЕсли;|<Логическое_выражение|Логическое выражение. ||> | ||Тогда |Операторы следующие за Тогда выполняются, если || |результатом логического выражения в конструкции Если || |является истина. ||//операторы |Исполняемый оператор или последовательность таких || |операторов. ||ИначеЕсли |Логическое выражение, следующее за ключевым словом || |ИначеЕсли вычисляется только тогда, когда условия в Если|| |и всех предшествующих ИначеЕсли оказались ложными. || |Операторы следующие за конструкцией ИначеЕсли — Тогда || |выполняются, если результатом логического выражения в || |данном ИначеЕсли является истина. ||Иначе |Операторы, следующие за ключевым словом Иначе || |выполняются, если результаты логических выражений в || |конструкции Если и всех предшествующих конструкциях || |ИначеЕсли оказались ложными. ||КонецЕсли |Ключевое слово, которое завершает структуру оператора || |условного выполнения. | Описание:Оператор Если управляет выполнением программы, основываясь на результатеодного или более логических выражений. Оператор может содержать любоеколичество групп операторов, возглавляемых конструкциямиИначеЕсли — Тогда.ПокаОператор выполнения цикла.Синтаксис:Пока <Логическое_выражение> Цикл //операторы;КонецЦикла;Параметры:|<Логическое_выражение|Логическое выражение. ||> | ||Цикл |Операторы, следующие за ключевым словом Цикл, || |выполняются, пока результатом логического выражения || |является истина. ||//операторы; |Исполняемый оператор или последовательность таких || |операторов. ||КонецЦикла |Ключевое слово, которое завершает структуру оператора || |цикла. |Описание:Оператор цикла Пока предназначен для циклического повторения операторов,находящиеся внутри конструкции Цикл ... КонецЦикла. Цикл выполняется покалогическое выражение — истина. Условие выполнения цикла всегда проверяетсявначале, перед выполнением цикла.ДляОператор выполнения цикла.Синтаксис:Для <Имя_переменной> = <Выражение1> По <Выражение2> Цикл //Операторы;КонецЦикла;Параметры:|<Имя_переменной>|Идентификатор переменной (счетчика цикла), значение которой|| |автоматически увеличивается при каждом повторении цикла. ||<Выражение 1> |Числовое выражение, которое задает начальное значение, || |присваиваемое счетчику цикла при первом проходе цикла. ||По |Синтаксическая связка для параметра <Выражение2>. ||<Выражение 2> |Максимальное значение счетчика цикла. Когда переменная || |Имя_переменной становится больше чем <Выражение2>, || |выполнение оператора цикла Для прекращается. Величина || |приращения счетчика при каждом выполнении цикла равна 1. ||Цикл |Операторы следующие за ключевым словом Цикл выполняются, || |пока значение переменной Имя_переменной меньше значения || |<Выражение2>. ||//Операторы |Исполняемый оператор или последовательность таких || |операторов. ||КонецЦикла |Ключевое слово, которое завершает структуру оператора || |цикла. |Описание:Оператор цикла Для предназначен для циклического повторения операторов,находящиеся внутри конструкции Цикл ... КонецЦикла. Перед началомвыполнения цикла значение <Выражение1> присваивается переменной<Имя_переменной>. Значение <Имя_переменной> автоматически увеличивается прикаждом проходе цикла. Цикл выполняется пока значение переменной<Имя_переменной> меньше или равно значению <Выражение2>. Величинаприращения счетчика при каждом выполнении цикла равна 1. Условие выполненияцикла всегда проверяется вначале, перед выполнением цикла.ПопыткаОбработка исключительных ситуаций.Синтаксис:Попытка // Некоторые действия;Исключение // Обработка исключительной ситуации;КонецПопытки;Параметры:|// Некоторые действия |Исполняемый оператор или последовательность таких|| |операторов. ||// Обработка |Исполняемый оператор или последовательность ||исключительной ситуации |операторов, которые обрабатывают исключительную || |ситуацию. ||Исключение |Операторы, следующие за ключевым словом || |Исключение выполняются, если при выполнении || |последовательности операторов произошла ошибка времени выполнения. ||КонецПопытки |Ключевое слово, которое завершает структуру || |оператора обработки исключительных ситуаций. |Описание:Оператор Попытка управляет выполнением программы, основываясь навозникающие при выполнении модуля ошибочные (исключительные) ситуации иопределяет обработку этих ситуаций.В качестве ошибочных (исключительных) ситуаций воспринимаются ошибкивремени выполнения модуля. Не предусмотрено определяемых пользователемисключений.Если при выполнении последовательности операторов произошла ошибка времени выполнения, то выполнение оператора, вызвавшегоошибку прерывается и управление передается на первый операторпоследовательности операторов . Приэтом управление будет передано даже в том случае, если ошибку вызвалоператор, находящийся в процедуре или функции, вызванной из . Если ошибка произошла в вызванной процедуре или функции, то еевыполнение будет прервано, а локальные переменные уничтожены. Этосправедливо для любой вложенности вызовов. После выполненияпоследовательности операторов управление передается на следующий за ключевым словом КонецПопыткиоператор. Если же последовательность выполниласьбез ошибок, то последовательность операторов будет пропущена и управление также будет продолжено с оператора,следующего за ключевым словом КонецПопытки.Конструкции Попытка-Исключение-КонецПопытки могут быть вложенными. Приэтом, при возникновении исключительной ситуации управление будет переданона самый «внутренний» обработчик, начинающийся с ключевого словаИсключение. Последовательность операторов может содержать оператор ВызватьИсключение (англоязычный синонимRaise). Выполнение данного оператора прекращает выполнениепоследовательности и производитсяпоиск более «внешнего» обработчика. Если таковой есть, то управлениепередается на его первый оператор. Если нет, то выполнение модуляпрекращается с выдачей сообщения о первоначально возникшей ошибке. ОператорВызватьИсключение может встречаться только внутри операторных скобокИсключение ... КонецПопытки.В выдаче диагностики помощь может оказать встроенная функцияОписаниеОшибки() (англоязычный синоним GetErrorDescription). Эта функция неимеет параметров, а в качестве значения возвращает описание ошибки, такоеже, как было бы выдано в окне сообщений, в случае отсутствия обработчикаисключительной ситуации, за исключением описания модуля и строки, в которойошибка возникла. Применять данную функцию имеет смысл только при выполнениипоследовательности операторов , таккак в ином случае она вернет пустую строку.ПерейтиБезусловная передача управления на другой оператор программы.Синтаксис:Перейти <Метка>;Параметры:|<Метка> |Метка другого исполняемого оператора в программе. |Описание:Безусловная передача управления на другой оператор программы. ОператорПерейти передает управление от одного оператора к другому. <Метка> в этомоператоре не должна быть меткой перехода на оператор Процедура или Функция.Область действия оператора Перейти ограничивается программным модулем,процедурой или функцией; он не может передать управление за пределыпрограммного модуля, процедуры или функции.Оператор безусловного перехода не может быть использован для передачиуправления на операторы, находящиеся внутри конструкций: Пока ...КонецЦикла, Для ... КонецЦикла, Если ... ИначеЕсли ... Иначе ... КонецЕсли,Попытка ... Исключение ... КонецПопытки извне этих конструкций.ПродолжитьПередача управления в начало цикла.Описание:Передает управление в начало цикла. Оператор Продолжить немедленно передаетуправление в начало цикла, где производится вычисление и проверка условийвыполнения цикла. Оператор Продолжить может использоваться только внутриконструкций операторов цикла Пока и Для.ПрерватьПрерывает выполнение цикла.Синтаксис:ПрерватьОписание:Прерывает выполнение цикла. Оператор Прервать приводит к немедленномупрекращению выполнения цикла и передает управление первому оператору,следующему за конструкцией оператора Пока или Для. Оператор Прервать можетиспользоваться только внутри конструкций операторов цикла Пока и Для.ВозвратЗавершение процедуры или функции.Синтаксис:Возврат [<Выражение>]Параметры:|<Выражение> |Выражение, значение которого содержит результат обращения к|| |функции. Этот параметр обязателен для оператора Возврат в || |теле описания функции, но не может использоваться в || |процедуре. |Оператор Возврат завершает выполнение процедуры или функции и передаетуправление в вызвавшую точку программы. Оператор Возврат обязателен вфункции и необязателен в процедуре. Если в процедуре не используетсяоператор Возврат, то его неявное выполнение происходит вслед за последнимисполняемым оператором процедуры. Данный оператор может применяться тольков теле описания процедуры или функции, причем <Выражение> может задаватьсятолько в случае использования оператора в контексте функции. Символы|Символ |Значение ||[ ] |В квадратных скобках заключаются необязательные синтаксические || |элементы. ||( ) |Круглые скобки заключают в себе список параметров. ||| |Вертикальной линией разделяются синтаксические элементы, среди || |которых нужно выбрать только один. |Специальные символы, используемые в исходном тексте|// |Двумя знаками «косая черта» начинается комментарий. Комментарием считается || |весь текст от знака "//" до конца текущей строки. ||| |Вертикальная черта в начале строки используется только в строковых || |константах и означает, что данная строка является продолжением предыдущей || |(перенос строки), (см. «Строковые константы»). ||~ |Знаком тильда начинается метка оператора. ||: |Двоеточием заканчивается метка оператора. ||; |Точка с запятой является символом разделения операторов. ||( )|В круглые скобки заключается список параметров методов, процедур и функций. ||[ ]|В квадратные скобки заключается размерность массивов. ||, |Запятая разделяет параметры в списке параметров методов, процедур и функций.||" "|В двойные кавычки заключаются строковые константы. ||' '|В одинарные кавычки заключаются константы даты. ||. |Десятичная точка в числовых константах. Разделитель, используемый в || |описаниях агрегатных типов данных. ||+ |Символ «плюс» обозначает операцию сложения. ||- |Символ «минус» обозначает операцию вычитания. ||* |Символ «звездочка» обозначает операцию умножения. ||/ |Символ «косая черта» обозначает операцию деления.
1   2

Похожие:

Реферат скачан с сайта allreferat wow ua iconРеферат скачан с сайта allreferat wow ua Политология. (реферат)

Реферат скачан с сайта allreferat wow ua iconРеферат скачан с сайта allreferat wow ua

Реферат скачан с сайта allreferat wow ua iconРеферат скачан с сайта allreferat wow ua

Реферат скачан с сайта allreferat wow ua iconРеферат скачан с сайта allreferat wow ua

Реферат скачан с сайта allreferat wow ua iconРеферат скачан с сайта allreferat wow ua

Реферат скачан с сайта allreferat wow ua iconРеферат скачан с сайта allreferat wow ua

Реферат скачан с сайта allreferat wow ua iconРеферат скачан с сайта allreferat wow ua

Реферат скачан с сайта allreferat wow ua iconРеферат скачан с сайта allreferat wow ua

Реферат скачан с сайта allreferat wow ua iconРеферат скачан с сайта allreferat wow ua

Реферат скачан с сайта allreferat wow ua iconРеферат скачан с сайта allreferat wow ua

Вы можете разместить ссылку на наш сайт:
Школьные материалы


При копировании материала укажите ссылку © 2013
контакты
uchebilka.ru
Главная страница


<